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1 WELCOME

This workshop provides a survey of popular open source geospatial software. The 

background of each project will be provided and you will have a chance to see how the 

different applications perform and what they are capable of.

The User-friendly Desktop Internet GIS (uDig) application is used to provide an 

introduction to geospatial concepts and ideas. The uDig application is integrated with the 

desktop experience with drag and drop support, features an embedded internet browser, and 

is available on a range of platforms.

For those new to the geospatial field we will cover how Features and Projections are used to 

draw your information onto a Map. We will also look into your enterprise needs ranging 

from use of PostGIS to working with Shapefiles. With access to more powerful data sources 

we will explore the range of styling and visualization options

Jody Garnett

Jody is the lead uDig architect and on the steering committee for GeoTools; GeoServer and 

uDig.  Jody Garnett is an employee of LISAsoft with a background in training and 

mentoring.

Mark Leslie

Mark has broad experience at LISAsoft integrating proprietary and open source solutions. 

An active PostGIS committee,r he has developed and extended software across the Open 

Source Geospatial stack, including UMN MapServer, PostGIS, uDig and GeoTools.  

Andrea Antonello

Andrea from HydroloGIS develops geospatial open source solutions for environmental 

analysis. Andrea is well known as the lead developer of the JGrass project and is part of the 

uDig project steering committee.
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2 LIVE DVD

Your conference program includes a Live DVD that includes a “pre” release of the uDig 

application; along with a full spread of popular open source geospatial software. We are 

going to be using the LiveDVD in today's workshop.

If you are following this tutorial at home you can either:

• Download the Live DVD from http://arramagong.org/   ; or

• Download and Install uDig and make use of the public servers mentioned

To start the live DVD:

1. Drop it in your computer

2. Restart (Some computers ask you to fiddle with your BIOS to start from a DVD?)

3. When presented with the first screen just press ENTER
(Or just wait 30 seconds for the boot screen to give up and do it for you)

Introduction 4/26

The Live DVD is  

useful for  

evaluating 

software – 

performance will  

be slower then a 

normal install..

http://arramagong.org/


4. At the user login screen you can enter “user” for the name, and “user” for the password.
(Or just wait 30 seconds for the login screen to give up and do it for you)

5. When presented with the desktop we are going to focus on the uDig application.
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If you like you 

can configure the 

network access at  

this time – 

allowing you to 

contact some of  

the services on 

the internet  

mentioned in this  

workbook.



6. I am not coordinated enough to double click on a linux desktop application to start it up; 
I recommend right clicking and choosing Execute.

7. Initially you are presented with the welcome screen.
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8. The initial welcome for linux users contains a warning – that frankly has not affected 
anyone on a computer made in the last four years. Please press OK to show the initial 
Welcome screen.

9. The welcome screen contains a link to the Getting Started tutorial from the online 
documentation.

We cover the use of the online documentation in the next section

10. The welcome screen contains a link to the Official Website 

11. To continue click on the Workbench arrow in the top right corner of the uDig welcome 
screen.
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You can return to  

the welcome 

screen at any 

time using the 

Help menu.



3 DOCUMENTATION AND TUTORIALS

In this section you will open up the online tutorial, and access reference information.

1. Open up the Help menu and select Help Contents

2. This will bring up the online help system; the help system is a web application that 
makes use of a Contents view to allow you to navigate between Pages.

3. The Contents view organizes Pages into Books. The following books are included with 
the uDig application

• User Guide

• Live User Guide – live access to the uDig web site

Additional books may be provided by community plug-ins you have installed.

4. You can access additional reference information in the following categories:

• Getting Started – Quickstart and the two formal walkthroughs

• Concepts – background information and definitions

• Tasks – step by step instructions on how to accomplish specific goals

• Reference – user interface reference describing each screen, wizard and dialog
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You can access  

the tutorials  

directly by 

pressing “Getting 

Started” on the 

welcome screen.



4 THE WORKBENCH

Before we start playing with maps, let’s take a look at the default layout of the uDig 

workbench and what some of the key components are.

Shown below is a typical session of uDig with the Map, Projects, Layers, and Catalog views 

labeled.  These views will be described further as we demonstrate their uses.
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5 CREATING A MAP

We can now start putting together a map.

1. Choose Layer > Add from the menu bar to open the Add Data wizard

2. Select Files from the list of data sources

3. Press Next to open a File Dialog; and navigate to user / data / udig-data as shown.

4. Select the clouds.jpg and countries.shp file and press OK.
(you can use the control key when clicking to select two things)
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5. A map will be created showing your two files.

6. You can also directly drag files onto the screen from the desktop; start by double-
clicking the Home icon on the desktop and navigate to the data directory again and drag 
in the cites file.

7. The map will now display cities.shp in the layer view – but we cannot see it!

8. The Layers view shows the order in which layers are drawn. Please select the Cities 
layer and press the Move up button from the Layer view toolbar, or simply drag the 
layer to the top.
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9. The order is now changed.

10. Now that you have some data on screen try the following tools:

•  Zoom Tool: (keyboard short cut Z)
Click or drag the left button to zoom in, or right button to zoom out.

•  Pan Tool: (keyboard short cut P)
Click and drag to move the display. 

•  Extent Tool: Press to show all

11. Congratulations and welcome to uDig!
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6 CONNECTING TO A WEB MAP SERVER

In this section you will learn how to drag and drop a Web Map Server (WMS) link into uDig 

for the purpose of viewing its layers.

If you are connected to the internet we recommend the DM Solutions MapServer listed on 

the following page:

•           http://udig.refractions.net/confluence/display/DATA/Home       

If not we can quickly start up a server included on the Live DVD.

1. Start GeoServer; either from the desktop or the Applications > Education > Start 
GeoServer menu.
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http://udig.refractions.net/confluence/display/DATA/Home


2. GeoServer will start with a small progress bar and then open Firefox to show you the 
welcome page.

For me Firefox was a little quick, and I had to hit refresh a couple of times while 
keeping the ctrl button held.

We can now add WMS layers:

1. There are many ways to load map data into uDig, including drag and drop.  To drag a 
Web Map Server (WMS) link into uDig, open up a web browser.

2. Close your previous “clouds” map (you can reopen later using the projects view).
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3. Click and drag theWMS link from the page onto the Map area, or Layers View on the 
left, and drop it there.

4. The Add Layers wizard will appear and ask you what layers from this WMS you want 
to show in your map. Select the first three layers – Manhattan (NY) landmarks, 
Manhattan (NY) points of interest, Manhattan (NY) roads and press the Finish 
button.

Introduction 15/26

If working with 

your windows 

maximized:

1) Drag from the 

web browser

2) Hover on the 

uDig application 

in the task bar to  
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3) Drop into the 

Map area.



5. The first thing to do is fix up our title; select the map in the project view, choose File > 
Rename and provide the title NY

6. The map layers will now render in the Map view.  Notice the bottom right corner of the 
uDig Application will display a processing notice while it is requesting and drawing the 
layers.

When the layers are done rendering, the Map view will display the visible layers
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rendering progress



7 CATALOG VIEW AND SEARCH VIEWS

In this section you will learn how to add additional layers to your map from a previously 

connected data source.

Adding a Layer from a previously connected WMS:

1. Double click to open your “clouds” map again; or change tabs if open on screen.

2. In the Catalog view expand the connection you have to GeoServer Web Map Service 
and right-click on “A sample Arcgrid file” and select Add to Current Map.

3. The new layer will appear in the Layers view, and it will automatically start to render. 
You may need to shuffle it to the bottom of the layer list using drag and drop or the 
provided buttons.

4. Since we really do not like the generic name of the layer, we rename it. That can be done 
by right-clicking on the layer in the Layers view and selecting rename.
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5. The catalog also comes equipped with a built in service called “Decoration.” Select 
Decoration  > Scalebar in the Catalog view and drag this layer onto the Map

Yes Australia is really dry.

6. Switch to the Search view and type in “states.”

7. All matching results are shown – layers work the same way here as they do in the 
catalog view. This time let us drag from the Search results directly to the layer view 
between countries and cites.
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Decoration are 

also available  

directly from the 

Layer menu.



8 THEMED DATA

The idea of colour coding the elements (or “features”) drawn on the map to communicate 

information is called a “Theme.” In this case we are going to choose an attribute to 

communicate; and then use the attribute values to dynamically color the featuers on a case 

by case basis.

1. Create a new map with your countries.shp and .jpg files.
To do this is to use File > New Map – and then drag the files in from the catalog. Check 
that your countries layers is on top of your clouds basemap.

2. The default style for the countries layer is slightly transparent so you can still see the 
pretty WMS layer underneath.

3. Right click on the countries layer and select Change Style.

4. The Style Editor is arranged into a series of pages, you can use the Simple style page to 
add labels to the countries layer.

• Check the box next to Label

• Choose “CNTRY_NAME” from the list.

5.

6. You can press the Apply button to see what your map will look like with labels.
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other settings,  
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7. Please switch to the Theme style page and select the following options:

• Attribute: POP_CNTRY

• Normalize: SQKM

8. Filter the available colour palettes to show a subset of those available:

• Changing from show “All” to show “Sequential”

• Press  the Colour-blind, LCD and CRT buttons
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9. Select the “light orange to dark red” palette, you can change the opacity if you like.

10. Press the Ok button to have a look at population density.

11. Choose  Layer > Legend from the menu bar to add a decoration showing the population 
breakdowns.

12. Press the  Mylar button in the Layers View. Select each layer and observe the effect.
This feature is used to allow you to make sense of a complicated map with many layers 
shown at once.
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Mylar will fade 

out all the layers 

except for the one 

selected.



13. Double click on your Map name along the top of the screen to maximize the editor.Try 
using the zoom tool to explore the world.

14. Double click on the Map tab to restore the previous size. You can use  Reset 
Perspective from the Window menu to restore any views you accidentally close during 
experimentation.
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Your layer view is  

still available on 

the left hand side  
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to toggle the layer 

view on and off  

as needed.



9 INFORMATION REQUEST

In this section, you will learn how to use the Information Tool.

1. Let us open up our first map NY map again

2. Zoom in somewhere interesting like Central park.

3. Use the Info tool to click on Central park

4. The results are listed in a new view that was opened. Select the result to view the web 
page (or other information).

5. You can switch to requesting information on another layer on the left pane. Available 
information, if any, is displayed on the right pane.

6. Not all Web Map Servers support the “GetFeatureInfo” operation; as such information 
may not be available for all layers. The application uses a normal browser to display 
HTML content; you can drag the view out of the workbench if you find you need more 
elbowroom.
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You can also 

double click on a 

Map to open it.



10 RE-PROJECTION

Since the world is not flat, maps are projected in a Co-ordinate Reference System (CRS). 

We will now make 2 identical maps, perform a re-projection on one, and compare.

1. Create a map from the udig-data directory files – bc_border, bc_pubs bc_voting_areas.

2. Press show-all to see the entire map -iInformation this close to the poles looks a little 
funny and stretched.

3. Click on the bottom of the map where it GCS_No...N_1983.
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4. This brings up the a preference page allowing you to change the Coordinate Reference 
System for your map. Please enter in  3005 and press enter to re-project the map to the 
“NAD 83 / BC Albers” coordinate reference system.

You can have a look at the formal definition of “EPSG:3005 by switching to the 
“Custom CRS” tab

5. Press the OK button to change the coordinate reference system of your map

6. One thing that is nice about this projection is that it is measured in meters; and the area 
of the polygons will be correct.

7. You can also choose a default scale for the map; or type in a scale to zoom in to a fixed 
level.
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You can also 

search by name,  
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11 WHAT TO DO NEXT?

Congratulations you have finished the first walkthrough. This is a bit of a tour of uDig, 

GeoServer, PostGIS and working with local files.

• There is more data available in the data directory - have a look !

• Try right-clicking on a Layer – there is plenty to do (try the operations menu).

• Does your organization publish any spatial information on the web?

• Try out the navigation tools such as Zoom and Pan (the Navigation menu lets you go 
back to previous locations like a web browser).

• Advanced: Open the Style Editor, have a look at the Advanced ( XML ) page and 
see what you make of it.

Perhaps you have an idea for the tool you always wanted?
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